E50 Problems with battery discharging

S

sonofpincher

Guest
#21
@sonofpincher, you SAY PROBABLY milli amps leakage but have you actually measured it?

10mA over 100 hrs is one amp hour lost in 4 days, hardly a flat battery scenario for a battery of 75Ahr or more.
Yes, but it was when I had central locking problems - dont ask! - and with an old battery. Tried to connect up through my "electric flight" Wattmeter, so as not to isolate the management system because of all the resetting it goes through. I did get between 0.1 & 0.2 amp "pulsing" unevenly, but couldn't come to any conclusion. What about my fuel gauge theory - might be more than a few milli-amps? Here to learn from more Elgranders.
 

stevemen

Here for life
Premium Member
E51 Owner
#22
My E50 has trickled away its battery charge ever since I got it 7 years ago. Changed battery, ensured interior lights isolated, etc. - still wont hold starting voltage for a week. Radio - not standard - isolated. Probably only milliamps leaking - but over time it gets down below 12v. Tell me, what powers the speedo mileage reading, and the fuel gauge, which stay set even when switched off?
If you happen to have remote starting disconnect it , it can flatten the battery over a few days unused
 

stevemen

Here for life
Premium Member
E51 Owner
#24
Stevemen, thanks - but what is the "bcm", please? But what I know about fuel gauges suggests a rheostat in the tank sender, which works the guage like a voltmeter, but calibrated in gallons - am I right? So my Elgrand is the only motor I've ever come across which shows the fuel content when switched off. Is some current therefore being supplied to the guage continually? Perhaps this is everyones problem!
If you fuel gauge is giving false readings, there's a Nissan recall for faulty fuel gauges...do a forum search u will find it mate
 
S

sonofpincher

Guest
#27
Failing that do a parasitic voltage test
Steveman - I have a voltmeter - how do you do that? Also, does your Elgrand hold its fuel reading switched off? Does everbody's? The gauge is accurate and working OK , but I'm just a bit puzzled.
 

stevemen

Here for life
Premium Member
E51 Owner
#28
Steveman - I have a voltmeter - how do you do that? Also, does your Elgrand hold its fuel reading switched off? Does everbody's? The gauge is accurate and working OK , but I'm just a bit puzzled.
Google it mate lots of vids showing you how to do a parasitic voltage test.
It's not usual for e50s I've come accross to hold voltage on fuel gauge when switched off
If you end up needing any parts I'm presently breaking e50s and e51s
Steve
 
S

sonofpincher

Guest
#29
Google it mate lots of vids showing you how to do a parasitic voltage test.
It's not usual for e50s I've come accross to hold voltage on fuel gauge when switched off
If you end up needing any parts I'm presently breaking e50s and e51s
Steve
Thanks, I'll do that. Always something new to learn. E50 parts - I'll make a note of that too.
 

Pipes

Newbie
E51 Owner
#30
Hi peps...I have a 2004 3.5 ltr e51 will battery prob...while running the car goes, well will only just drive...into limp mode I’ve had alternator checked new battery and still same prob...beginning to think it could be a ECU any ideas....so far its been a month of fing about with wiring in a second battery to keep it running..?
 

stevemen

Here for life
Premium Member
E51 Owner
#31
Hi peps...I have a 2004 3.5 ltr e51 will battery prob...while running the car goes, well will only just drive...into limp mode I’ve had alternator checked new battery and still same prob...beginning to think it could be a ECU any ideas....so far its been a month of fing about with wiring in a second battery to keep it running..?
If it has remote start switch it off. Switch is near accelerator pedal.
Otherwise do a parasitic voltage test.
Steve
Tojomotorsuk
 

stevemen

Here for life
Premium Member
E51 Owner
#32
If it has remote start switch it off. Switch is near accelerator pedal.
Otherwise do a parasitic voltage test.
Steve
Tojomotorsuk
You say with battery problem. Does it start ok? Is the problem arising only when your driving?
If it starts ok then loses power thats a different matter
 

Pipes

Newbie
E51 Owner
#33
It starts ok then the brake and alternator lights start to flash occasionally then I can drive for a while and then it goes into limp mode....I then stop turn it off.....and restart it ok but it will only just drive....I’m guessing it’s because it’s short of electrical power to the auto box, cos the engine turns over ok and the lights stay bright.....the alternators been off a few times now
 

Reuben

Member
Premium Member
E51 Owner
#34
Found out that our E51 camper conversion’s battery was flat after packing for a weekend away yesterday! Been meaning to check after the very cold weather up here - but found out the hard way....Anyhoo, Just got a CTEK 5 charger to recharge & maintain over Winter. Is it correct that the Elgrand’s battery has reverse polarity? Also when charging with the battery in situ is there a designated earthing point or do I just clip up the battery? Cheers.
 

Reuben

Member
Premium Member
E51 Owner
#35
Hi Pipes, had a similar problem with warning lights coming on. We stopped then restarted & the lights went out. Turned out the problem was something to do with box behind the dash that was fitted to convert KMs to miles shorting out. This was triggering the warning lights, we had no loss of power. Ours is under warranty so it went back to the dealer who sorted it. Whilst we love the car & camper conversion we’ve had a lot of niggles, not being a part time mechanic or electrical engineer it’s a pain in the arse. Could be getting something European next time - we’ll see........
 

Alan Morgan

Here for life
Premium Member
E51 Owner
#36
........Is it correct that the Elgrand’s battery has reverse polarity?
The Elgrand IS NOT reverse polarity - The battery negative goes to the chassis
Also when charging with the battery in situ is there a designated earthing point or do I just clip up the battery? Cheers.
Just connect the charger across the battery terminals.
 

Reuben

Member
Premium Member
E51 Owner
#37
Cheers Alan - I knew someone would stop me blowing myself up!! I picked the info up on rev polarity in the ‘E51 Frequently Asked Questions’ thread posted by mattd. I’ve probably interpreted it wrong.
 
Last edited: