Picked up My E51.

Dave M

Active Member
Premium Member
#1
Hope it's ok to post this on here.
Just picked up my Elgrand which I bought from Jason at Duxford Automotive. Have to say I'm well chuffed, it drove home lovely. Jason is a really nice guy and has done everything he said he would do and more. He even told me about a cover that was missing under the van which he has ordered for me, I doubt I would have ever noticed it was missing. My E51 is a 720000 mile white Rider with twin sunroofs, standard alloys and leather seats. Nothing to do to it apart from figuring out what all the buttons do. Also as the seats had some marks on them Jason had them recoloured for me and whilst the seats were out they found a remote start transmitter. It bleeps inside the van when it's pressed but nothing happens so that's something to investigate. Only down side of today is its misarable weather and I started off my 100 mile plus journey home with a lovely clean van and now it's filthy. Tomorrow will be spent cleaning my Elgrand.
I have no connection with Jason apart from buying my Elgrand from him.
 

Richard Fox

Double Elgrand Obession!
Premium Member
E51 Owner
#3
Just found pics of yours, very nice.... if you want I can post the pics for you? Have you still got the flare I see it in the pics?! lol
 

Whotsit

Well-Known Member
Premium Member
E51 Owner
#12
Hope it's ok to post this on here.
Just picked up my Elgrand which I bought from Jason at Duxford Automotive. Have to say I'm well chuffed, it drove home lovely. Jason is a really nice guy and has done everything he said he would do and more. He even told me about a cover that was missing under the van which he has ordered for me, I doubt I would have ever noticed it was missing. My E51 is a 720000 mile white Rider with twin sunroofs, standard alloys and leather seats. Nothing to do to it apart from figuring out what all the buttons do. Also as the seats had some marks on them Jason had them recoloured for me and whilst the seats were out they found a remote start transmitter. It bleeps inside the van when it's pressed but nothing happens so that's something to investigate. Only down side of today is its misarable weather and I started off my 100 mile plus journey home with a lovely clean van and now it's filthy. Tomorrow will be spent cleaning my Elgrand.
I have no connection with Jason apart from buying my Elgrand from him.

Congratulations, hope you enjoy yours as much as I do mine, but but but! I do hope you've made a mistake with the milage, good luck with her.
 

Karl

Founder
Staff member
E50 Owner
Premium Member
E50 Expert
#16
The remote start... I'm guessing when you say transmitter, you mean the fob to start it.

I had one on mine that bleeped but nothing happened.

I found the control box behind the drivers side dash with the earth disconnected. Wired it up, followed the pairing instructions and bingo. Remote start.

Be warned though, insurance companies do not like them, so although they are a fun gimmick for shows, be extremely careful with them on the road.
 

Phill1

Well-Known Member
E51 Owner
#17
Hope it's ok to post this on here.
Just picked up my Elgrand which I bought from Jason at Duxford Automotive. Have to say I'm well chuffed, it drove home lovely. Jason is a really nice guy and has done everything he said he would do and more. He even told me about a cover that was missing under the van which he has ordered for me, I doubt I would have ever noticed it was missing. My E51 is a 720000 mile white Rider with twin sunroofs, standard alloys and leather seats. Nothing to do to it apart from figuring out what all the buttons do. Also as the seats had some marks on them Jason had them recoloured for me and whilst the seats were out they found a remote start transmitter. It bleeps inside the van when it's pressed but nothing happens so that's something to investigate. Only down side of today is its misarable weather and I started off my 100 mile plus journey home with a lovely clean van and now it's filthy. Tomorrow will be spent cleaning my Elgrand.
I have no connection with Jason apart from buying my Elgrand from him.
Looks tidy did your dealer service it in any way ie Oil change Filter change if not I'd get those 2 things done for peace of mind - plenty of advice on which engine oil to go for on the Forum (search)

Good to see it's been De cated - is it undersealed ?
 

Dave M

Active Member
Premium Member
#18
Looks tidy did your dealer service it in any way ie Oil change Filter change if not I'd get those 2 things done for peace of mind - plenty of advice on which engine oil to go for on the Forum (search)

Good to see it's been De cated - is it undersealed ?
Hi Phil
Yea, full service, discs and pads all round, de cated, under sealed, two keys one is new, double din stereo fitted, four new tyres even though ones it came in with looked fine. 3 months warranty. Plus due to it getting some damage during shipping Jason replaced the rear light strip as it was cracked and the number plate garnish as is had a small dent. Also it's going in to have a new screen cos when his valeter took it to have the underselling done it came back with a cracked screen. I'm really pleased with it.
 

Dave M

Active Member
Premium Member
#19
The remote start... I'm guessing when you say transmitter, you mean the fob to start it.

I had one on mine that bleeped but nothing happened.

I found the control box behind the drivers side dash with the earth disconnected. Wired it up, followed the pairing instructions and bingo. Remote start.

Be warned though, insurance companies do not like them, so although they are a fun gimmick for shows, be extremely careful with them on the road.
Thanks for the info Karl, are the earths disconnected as a matter of course before they are shipped, seems odd but I will check mine when I stop fiddling with the bits that do work.
 

Dave M

Active Member
Premium Member
#20
Thanks for the info Karl, are the earths disconnected as a matter of course before they are shipped, seems odd but I will check mine when I stop fiddling with the bits that do work.
The remote start... I'm guessing when you say transmitter, you mean the fob to start it.

I had one on mine that bleeped but nothing happened.

I found the control box behind the drivers side dash with the earth disconnected. Wired it up, followed the pairing instructions and bingo. Remote start.

Be warned though, insurance companies do not like them, so although they are a fun gimmick for shows, be extremely careful with them on the road.
Hi Karl, do you still have the pairing instructions, think mine needs pairing.