E50 E50 3.2td cutting out whilst driving

#1
Hi, Our 1998 elgrand 3.2td 4x4 qd32eti has started to sometimes hic up as you drive along bringing eml on then it will clear and drive fine within 5 minutes. Just this week it has started to do it again then cut out, it will restart almost immediately but its a worry as we use it to ferry the kids around. Its just had a full service but nothing has been found. have cleaned the maf sensor but it wasn't visibly dirty. Any help welcomed. Is there any program to read the codes? Thanks for your time
Davey and Bev
 
#3
Hi ive just managed to flash read the code and it comes up with 11 and 47 which i think is a crankshaft sensor. Fingers crossed will clean it but anyone bought one?
Thanks for your quick replies
 

Karl

Founder
Staff member
E50 Owner
Premium Member
E50 Expert
#4
It's not something I had to do on my last E50 (3.2) but it has been something brought up quote often. Do a search of the forum because it has most definitely been covered at some point. There are spares available for it, so don't worry. You'll probably find the sensor from a 2.7 Terrano fits (QD27 - just a smaller version of the QD32).
 

Steve~Mk1

Here for life
E50 Owner
Premium Member
#10
It's not something I had to do on my last E50 (3.2) but it has been something brought up quote often. Do a search of the forum because it has most definitely been covered at some point. There are spares available for it, so don't worry. You'll probably find the sensor from a 2.7 Terrano fits (QD27 - just a smaller version of the QD32).
That might be one of the different bits between the TD27 & QD32, as (depending on year) the crank sensor's in a different place - up front on the QD32, and by the belhousing (I think) on the TD27. If the part numbers match on the Partsouq database though, no worries.
 
Last edited:

Jasper

Active Member
E50 Owner
#18
It will be interesting to know if it's fixed your problem, as like Karl said it's been mentioned in relation to various symptoms over the years but I'm not sure if it's ever resolved anything?
I even changed mine at one point for something completely unrelated, but it turned out to be a red herring.
Good luck!