Corrosion Areas

Drdax

Well-Known Member
E50 Owner
Ive just taken the maf off to clean it. Is there any way of removing the sensor or the gauze to clean it better?
 

Steve~Mk1

Here for life
E50 Owner
Premium Member
Ive just taken the maf off to clean it. Is there any way of removing the sensor or the gauze to clean it better?
There are two screws on top of the 'maf tube' that should allow you to take the maf sensor right out of the tube.
 

Drdax

Well-Known Member
E50 Owner
my Turbo inlet pipe is split so I’ve managed to source a samco one. Is it normal to have a bit of oil residue in the pipe and turbo inlet? Is this why people fit a catch tank on the smaller pipe?
 

Steve~Mk1

Here for life
E50 Owner
Premium Member
my Turbo inlet pipe is split so I’ve managed to source a samco one. Is it normal to have a bit of oil residue in the pipe and turbo inlet? Is this why people fit a catch tank on the smaller pipe?
I've fitted a catch can to mine (you can see in the old pic above), but I've been told oil in the intake is normal on a turbo diesel due to the sky high compression levels, which cause some degree of blow-by on the rings. Every turbo diesel I've since seen has it to some degree.

Unless the blow by is horrendous, the biggest problem it might cause is carbon build up in the intake if the EGR allows exhaust gas to mix with the oil vapour - this is one of the things that can lead to the ZD30 diesel grenading, but would probably only lead to poor performance on the QD32. If you disable the QD32 EGR with a small piece of 6mm hose, no carbon can form (in theory).
 

Drdax

Well-Known Member
E50 Owner
Phew, I’m glad it’s normal then! Looks like my hose had been split for a long time and the oil was escaping anyway. It’s a right mess around the turbo. Will need a good clean up before I fit the new hose. Will look into catch tanks etc 👍🏻
 

Drdax

Well-Known Member
E50 Owner
Well I’ve been over and had a few parts off a fellow forum member. So I now have a nice samco turbo hose fitted. I’ve also done a load of other jobs with the other parts. Most were silly little things that were missing or broken! Well chuffed 😀
 

Drdax

Well-Known Member
E50 Owner
Well I’ve just had my new tyres done and what a difference! I’ve gone for 225/50 17XL. It turns out both original rear tyres were run flats and one had been ran flat! Also it’s running loads better with cleaned MAF and new turbo hose 😀
 

Drdax

Well-Known Member
E50 Owner
Yes am well chuffed 😀

Well I’ve not had the light flash since driving it home from buying it and all is still well. I just need to get the 4x4 to activate to see if it’s ok. I did have a bit of wheel spin earlier but perhaps not enough.
 

Drdax

Well-Known Member
E50 Owner
A quick question on the 4x4 system. I’m assuming when it kicks in the lights for the front wheels turn on in the dash?