FOR SALE Breaking E50 3.2TD Allmode 4x4

Cerberus83

Active Member
E50 Owner
Premium Member
#41
what condition is the windscreen wiper linkage in, rear shock absorbers, and steering rack mounts
I havent had a look at the wiper linkage,but I know it works.I will try and get out tomorrow morning to have a look at it.I know the wipers were working before I took her off the road.As for the other parts,I will have to have a look at them and get back to you.
 

rallychief

Member
E50 Owner
#43
The wipers will still work with the nylon spindle housings quite badly worn. but the arms will move up and down quite a bit, mine is so bad on one side it was catching the bonnet
 

Cerberus83

Active Member
E50 Owner
Premium Member
#48
The wipers will still work with the nylon spindle housings quite badly worn. but the arms will move up and down quite a bit, mine is so bad on one side it was catching the bonnet
I managed to have a quick look this morning and I think they are ok.I only had time to take the plastic cover off for a look before I had to go to work.Now I just need to figure out how to get the lot off.Haha.Ill be back at it tomorrow night after work.
 

rallychief

Member
E50 Owner
#49
when you come to unbolt the wiper motor it is easier to pull it off the ball and socket above it, then 6 nuts 3 each on the triangular nylon housings, they are on studs which are only kept captive by a spline in the nylon be careful one of mine just spun around, then fiddle it out, if the holes in the nylon housings the spindles turn in, are at all oval and the spindles not tight top and bottom of the housing, they are worn, i am hazarding a guess it is a common problem
 

Cerberus83

Active Member
E50 Owner
Premium Member
#50
when you come to unbolt the wiper motor it is easier to pull it off the ball and socket above it, then 6 nuts 3 each on the triangular nylon housings, they are on studs which are only kept captive by a spline in the nylon be careful one of mine just spun around, then fiddle it out, if the holes in the nylon housings the spindles turn in, are at all oval and the spindles not tight top and bottom of the housing, they are worn, i am hazarding a guess it is a common problem
Thanks for that.I will get a good look tomorrow after work and get back to you then if that's ok?Wont be home till late tonight so wont get a chance now.
 
#52

JEades

Newbie
E50 Owner
#54
Managed to get them off in one piece along with the clips.You will need some new 3M tape or something to stick them back on though,as the old strips are knackered.
Spot on thanks.
Are they in decent nick?

I'll have them if they are. Wouldn't mind sending a photo over if you get chance?
 

Cerberus83

Active Member
E50 Owner
Premium Member
#55
Spot on thanks.
Are they in decent nick?

I'll have them if they are. Wouldn't mind sending a photo over if you get chance?
Theu seem ok.Ill get you some pictures when I'm out at the car.Just about to have my dinner so will probably be about an hour or so.